Jump to content
DenariusTalk
jtmining17

Wallet does not stake

Recommended Posts

Hello all,

Just starting up in the mining market, I read through other threads about mining and staking but cannot get my wallet to stake at all. My wallet is encrypted but unlocked and has been connected to the network for days but does not stake at all.  I've copied my denarius.conf below, am I missing something? I've pieced together everything I could find.   Is my username and password supposed to be something specific or can it be anything?

 

rpcuser=my username
rpcpassword=my password
rpcallowip=127.0.0.1
rpcport=32339
server=1
daemon=1
listen=1
staking=1
addnode=104.233.106.135:33339
addnode=109.205.244.150:33339
addnode=115.207.158.4:33339
addnode=130.255.12.2:33339
addnode=142.105.20.251:33339
addnode=147.135.191.162:33339
addnode=159.118.167.26:33339
addnode=163.172.4.66:33339
addnode=167.114.103.43:33339
addnode=172.93.53.210:33339
addnode=173.150.158.71:33339
addnode=189.186.121.70:33339
addnode=192.3.196.202:33339
addnode=200.92.17.152:33339
addnode=36.81.2.210:33339
addnode=37.146.173.97:33339
addnode=49.169.43.77:33339
addnode=5.9.112.62:33339
addnode=73.135.197.253:33339
addnode=75.174.67.156:33339
addnode=77.38.55.82:33339
addnode=82.114.227.101:33339
addnode=82.114.227.188:33339
addnode=82.114.234.204:33339
addnode=82.114.238.71:33339
addnode=82.114.251.198:33339
addnode=85.108.170.179:33339
addnode=88.254.45.178:33339
addnode=91.77.206.228:33339
addnode=94.250.129.128:33339

Share this post


Link to post
Share on other sites

@jtmining17 The RPC User and Password values can be set to anything. The main setting here you want is the staking=1. Everything looks fine in your conf to me, so the next thing I would check is by going to in the wallet "Help->Debug Window->Console" and then type in "getstakinginfo" please paste what is found here :D if your wallet is encrypted you need to ensure it is unlocked for staking via the GUI as well.

  • Thanks 1

Share this post


Link to post
Share on other sites

@Carsen Thanks for the reply please see the debug below. It says that is enabled but shows that its not staking. Sorry if I have any incorrect observations, also trying to learn as I go along.

 

image.png.7f5d773e25951877b8b0db04009dfa2d.png

 

18:04:43

cmd-reply

Welcome to the Denarius RPC console.
Use up and down arrows to navigate history, and
Ctrl-L to clear screen.
Type
help for an overview of available commands.

 

18:03:30

cmd-request

getstakinginfo

 

18:03:30

cmd-reply

{
"enabled" : true,
"staking" : false,
"errors" : "",
"currentblocksize" : 1000,
"currentblocktx" : 0,
"pooledtx" : 0,
"difficulty" : 0.00024414,
"search-interval" : 1,
"weight" : 0,
"netstakeweight" : 3546,
"expectedtime" : -1
}

 

 

 

Edited by jtmining17

Share this post


Link to post
Share on other sites

Yup everything looks good there! Your wallet is setup for staking, note the enabled: true certifies staking is enabled for your wallet, staking: false, just means it is not currently staking as your weight is also 0. You need to have coins that have matured for a minimum of 8 hours. It can take some time to find a PoS block due to PoW making generally 70% of blocks right now.

  • Thanks 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×