Jump to content
DenariusTalk

Recommended Posts

@badbad You may need to do the flag --gpu-platform=1 (2 or 3, etc.) to ensure your GPUs are being used by sgminer, sometimes it will default to using your integrated graphics instead of the GPUs.

Quoted from @enkayz

Quote

Try booting with --gpu-platform 1:

sgminer.exe -k tribus --gpu-platform 1 -o stratum+tcp://pool.hashbag.cc:8688 -u <mywallet> -p c=DNR

to double check the gpu platform you want to run with run "sgminer.exe -n" it should show your gpu platforms that are installed, more than likely platform 0 is the intel opencl

If all else fails or if you just want to remove the intel opencl platform check in this registry key:

HKEY_LOCAL_MACHINE/Software/Khronos/OpenCL/Vendors OR
HKEY_LOCAL_MACHINE/Wow6432Node/Software/Khronos/OpenCL/Vendors

it should list your openCL vendors. if the intel opencl is in there set the DWORD value to 1, then it should disappear from the platform enumeration and your AMD OpenCL will be the '0'th gpu platform

 

Share this post


Link to post
Share on other sites
On 7/19/2017 at 3:35 PM, badbad said:

what you use driver version i can not run SGminer 5.3.8. i use AMD 7990 , and AMD r9 Nano on windows 10 .

AMD Driver T test 15.12,16.12.1, 17.1.1 , 17.51 , 17.7.1 Can not run Sgminer no create .bin file

thank you,

By chance are you trying to run the miner from a network or mapped drive? Z: drive is a common mapped drive - and the batch files won't work on a network/mapped drive, only an actual drive such as C:
 

On 7/19/2017 at 3:21 PM, bobbyg said:

When using ccminer for nvidia on windows 64 bit, do I need to change the "ccminer.conf" file?

No, the ccminer.conf file is only used if you start ccminer with the '-c' option. if you are starting ccminer with the usual command line options that specify the pool address and worker names, the .conf file is not used. it is only really included as an example.

Share this post


Link to post
Share on other sites
4 hours ago, enkayz said:

updated ccminer available now with improved DNR algo

https://hashbag.cc/ccminer-2.2-skunk.zip includes hashbag urls in the batch files

 

original 7z version at http://ccminer.org/preview/ccminer-2.2-skunk.7z

 

Updated main post with links to your improved ccminer :) Good work!

Share this post


Link to post
Share on other sites

Hey Guys...I'm a NOOB and I admit it. I need additional help with my setup. I am trying to get my ATI R9 290 on my main tower to run sgminer 5.3.8 (until I can build my new rig) and mine a little Denarius while I sleep. I am using the following .bat file:

sgminer.exe -o stratum+tcp://pool.hashbag.cc:8688 -u <wallet account> -p x pause

It tries to run...but I get the following screens:

I tried reading the forum...but I do not seem to understand as much as I should, and the SGminer help is not as popular as the CCminer is.

Can anyone help me to get this up and running?

SGminer1.png

sgminer2.png

Edited by khatmando

Share this post


Link to post
Share on other sites
14 hours ago, juniormasters said:

the only reason is that i have too many wallets on my PC already lol
but no problem, lets install another one :D

I sure understand this... DNR is available to use on the Coinomi mobile wallet. If it wasn't the main wallet I keep open all the time to stake, I'd use that. I use it for most other altcoins I'm holding.

Share this post


Link to post
Share on other sites
6 hours ago, khatmando said:

Hey Guys...I'm a NOOB and I admit it. I need additional help with my setup. I am trying to get my ATI R9 290 on my main tower to run sgminer 5.3.8 (until I can build my new rig) and mine a little Denarius while I sleep. I am using the following .bat file:

sgminer.exe -o stratum+tcp://pool.hashbag.cc:8688 -u <wallet account> -p x pause

It tries to run...but I get the following screens:

I tried reading the forum...but I do not seem to understand as much as I should, and the SGminer help is not as popular as the CCminer is.

Can anyone help me to get this up and running?

SGminer1.png

sgminer2.png

Make sure you have already done the following :

1) Download the latest AMD drivers, or the latest ones compatible with your r9.

2) I had similar problems with sgminer 5.3.8, try using sgminer 4.1.0 ( https://github.com/carsenk/sph-sgminer-tribus/releases/download/1.0-tribus/sph-sgminer-tribus.zip ). That solved my problem.

3) I don't know if the post shows like that your batch file Lines, but the pause command is in a NEW Line to mine, like this:

 

sgminer.exe -o stratum+tcp://pool.hashbag.cc:8688 -u <wallet account> -p x 

pause

 

Hope this helps, waiting for your reply!

Share this post


Link to post
Share on other sites

Above the command sgminer.exe ...... in your bat file add these Lines:

 

setx GPU_FORCE_64BIT_PTR 0
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_SINGLE_ALLOC_PERCENT 100

 

I believe sgminer do this automatically, but you never know. Try it and let us know!

Share this post


Link to post
Share on other sites

As always...Thanks for the help!

I took Minerius's suggestion and added his suggestions to my .bat file:

setx GPU_FORCE_64BIT_PTR 0
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_SINGLE_ALLOC_PERCENT 100
sgminer.exe -o stratum+tcp://pool.hashbag.cc:8688 -u <wallet> -p x 
pause

 

I received the following 2 screens:

 

It looks like a step or two forward...but a GPU issue is still occurring.

And Yes.... my drivers are up to date.

 

sg4.png

sg5.png

Share this post


Link to post
Share on other sites

try looking in the kernel folder of your sg miner to see if the tribus.cl file is in there, if not download an updated version of sg miner and try this work around that works for me.

replace your config file with mine( i added it to this post) no need to add setx gpu text, its in the config file, edit it and enter your wallet address, once complete double click DNR.CMD, wait for window to start, it will say WTF 0 pools selected or something like that, once ready it will show the main screen and if you only have 1 card running press G, then E the card number from 0-5 or however many cards you have, after each one press enter.

for example G, wait for window to change, E, 1 press enter and repeat for all cards not showing as being on

hope this helps, it took many hrs to figure this out and get mining

sgminer-dnr.conf

Share this post


Link to post
Share on other sites
9 hours ago, tex6246 said:

try looking in the kernel folder of your sg miner to see if the tribus.cl file is in there, if not download an updated version of sg miner and try this work around that works for me.

replace your config file with mine( i added it to this post) no need to add setx gpu text, its in the config file, edit it and enter your wallet address, once complete double click DNR.CMD, wait for window to start, it will say WTF 0 pools selected or something like that, once ready it will show the main screen and if you only have 1 card running press G, then E the card number from 0-5 or however many cards you have, after each one press enter.

for example G, wait for window to change, E, 1 press enter and repeat for all cards not showing as being on

hope this helps, it took many hrs to figure this out and get mining

sgminer-dnr.conf

Sgminer 5.3.8

Sample 4 Gpu

DNR.cmd
 

@echo off
echo "starting up sgminer" 

@setx GPU_FORCE_64BIT_PTR 0
@setx GPU_MAX_HEAP_SIZE 100
@setx GPU_USE_SYNC_OBJECTS 1
@setx GPU_SINGLE_ALLOC_PERCENT 100

Call :start

pause
GOTO ENDE


:start

@set GPU_MAX_ALLOC_PERCENT = 100

DEL /F *.bin
sgminer.exe -c sgminer-dnr.conf -d 0,1,2,3 -g 4 
--gpu-platform 1
EXIT /B 0

:ENDE

Share this post


Link to post
Share on other sites
21 hours ago, tex6246 said:

try looking in the kernel folder of your sg miner to see if the tribus.cl file is in there, if not download an updated version of sg miner and try this work around that works for me.

replace your config file with mine( i added it to this post) no need to add setx gpu text, its in the config file, edit it and enter your wallet address, once complete double click DNR.CMD, wait for window to start, it will say WTF 0 pools selected or something like that, once ready it will show the main screen and if you only have 1 card running press G, then E the card number from 0-5 or however many cards you have, after each one press enter.

for example G, wait for window to change, E, 1 press enter and repeat for all cards not showing as being on

hope this helps, it took many hrs to figure this out and get mining

sgminer-dnr.conf

AMD Old GPU 7Xxx,2Xx I use driver 16.2 .1 - 16.11.5 My best for tribus 16.4 - 16.11.5 can OC

Set -I 21-22 

Share this post


Link to post
Share on other sites
13 hours ago, badbad said:

Sgminer 5.3.8

Sample 4 Gpu

DNR.cmd
 

@echo off
echo "starting up sgminer" 

@setx GPU_FORCE_64BIT_PTR 0
@setx GPU_MAX_HEAP_SIZE 100
@setx GPU_USE_SYNC_OBJECTS 1
@setx GPU_SINGLE_ALLOC_PERCENT 100

Call :start

pause
GOTO ENDE


:start

@set GPU_MAX_ALLOC_PERCENT = 100

DEL /F *.bin
sgminer.exe -c sgminer-dnr.conf -d 0,1,2,3 -g 4 
--gpu-platform 1
EXIT /B 0

:ENDE

thnx this got my system running with 4 cards, nice job

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×